PGV verlangt das Anlegen eines neuen Admin

  • Moin Zusammen!


    Ich habe nun schon eine Weile PGV auf meiner Website und es hat immer super funktioniert.


    Nun gehe ich heute morgen auf die HP und auf den Bereich mit GedView und werde ich auf die "Editconfig.php" geleitet und ich solle doch bitte einen Admin anlegen.


    HÄÄÄÄÄÄ???????


    Hatte ich doch schon mal alles gemacht und schon über 34000 Besucher.


    Zitat:

    Quote

    PhpGedView konfigurieren
    Willkommen auf Ihrer neuen PhpGedView-Website. Da sie diese Seite angezeigt bekommen, haben Sie PhpGedView auf Ihrem Webserver schon erfolgreich installiert und sind nun bereit, es nach Ihren Vorstellungen zu konfigurieren.



    Erstellen Sie den Hauptadministrator.
    Sie müssen zunächst den Hauptadministrator erstellen. Dieser Benutzer wird das Recht erhalten, die Konfigurationsdateien zu verändern, private Daten zu sehen oder andere Benutzer zu erstellen.


    Ich habe schon in der Log-Datei nachgesehen, aber da war nichts aussergewöhnliches zu finden.


    Wie kann sowas sein? Im Webspace ist auch nichts zu finden.


    Kann mir da Jemand weiterhelfen? Nicht das sich da doch jemand eingeschlichen hat und ich dann Daten an den Vogel weiterleite oder ihm das Tor öffne.


    Achso die Prog-Version ist die 4.xx




    Gruß Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka

  • Hallo Gordon,


    es sieht nach einem Hack-Versuch aus.
    Wenn Du in die Editconfig.php umgeleitet wirst, bedeutet das, dass die config.php weg ist.
    Entweder hast Du irgendwas gemacht, umgenannt oder gelöscht, oder es war jemand fremdes.
    Zuerst würde ich alle Passwörter für Deinen Webspace neu setzen, auch den für mySQL und die letzte config.php zurückspielen.
    Ich selber habe immer die ganze PGV nochmal lokal gesichert und spiele diese im Fehlerfalle komplett zurück. Man muss nur noch dann das mySQL Passwort ändern.


    Ich gehe mal mit ICQ online, kannst mich ansprechen. Wenn es etwas dauert bis ich reagiere dann, wechsele ich gerade auf den Laptop auf der Terasse um das schöne Wetter zu genießen.


    Im Moment glaube ich, dass bevor Du alles wieder hochlädst Ursachenforschung notwendig ist, ob es denn wirklich ein Hacker war und wenn ja, wie das passiert ist.

    Gruß
    Michael Lauffs
    Aachen, Eschweiler, Stolberg
    ICQ# 48430007
    www.Lauffs.de

    Man sollte eine Dummheit nicht zweimal machen, es gibt doch so viele davon.

  • Hmm,


    also das letzte was ich gemacht hatte, war am 10.06.2006. Da habe ich ein paar User gelöscht, die eh nur einmal reingeschaut hatten und das vor ´nem halben Jahr.


    Wenn ich mir mittels FTP-Prog bei den Dateien das Datum der letzten Änderung anschaue, dann ist das auch das letzte Datum was auftaucht.


    Sicherlich könnte ein Hacker das Datum auch so hindrehen, das es nicht auffällt.


    Die Config-Dateien sind alle vorhanden. ?(


    Naja, da heißt es "Lernen durch Schmerz"! Ab jetzt werde ich mir dann wohl alle paar Wochen mal ´ne Backup ziehen. Meine letzte ist leider vom Januar.


    Wie muss ich das jetzt mit dem Backup.zip machen?





    Gruß Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka

  • Was mir eben noch einfällt, kannst Du mal prüfen auf welchen Rechten die config.php sitzt ? Vielleicht liegt dort der Hase im Pfeffer.


    Desweiteren prüfe noch ob die authenticate.php da ist bzw. die richtigen Rechte hat. In dieser Datei sind die User gespeichert.


    Welchen Provider hast du ?

    Gruß
    Michael Lauffs
    Aachen, Eschweiler, Stolberg
    ICQ# 48430007
    www.Lauffs.de

    Man sollte eine Dummheit nicht zweimal machen, es gibt doch so viele davon.

  • Hallo Michael!


    Die Config steht auf 444.


    Diese authenticate.php habe ich nicht. Die war aber auch nicht Prog-Paket beim Download und Upload vorhanden.


    Mein Provider ist 1und1. Und ich hatte da auch noch nie Probleme.


    Wie kann ich herausfinden, ob jemand PGV gehack hat. Und das muss ja einer gemacht haben, denn von heute auf morgen wird ja nicht die Config gelöscht bzw. die Einstellungen.




    Gruß Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka

  • Den Provider musste ich nur wissen um zu vergleichen, ob ich auch Gefahr laufe. Meiner ist allinkl.com.
    Ich habe kürzlich einen Artikel bei Heise.de gelesen, darin hat ein spezialist vor schlampigen php Implementierungen seitens der Provider gewarnt. Ich muss mal sehen ob ich den Artikel wieder finde.


    die Authenticate.php ist nicht im original Package drin, weil sie erst beim anlegen des ersten Users, nämlich dem Admin generiert wird.
    Du solltest dir diese aus Deiner letzten Datensicherung wieder auf den Server kopieren. sie muss im \index liegen.


    Es ist auf jeden Fall besser einzelne Dateien zurückzuspielen als die ganze Installation nochmal von vorne zu machen. Der Versuch ist es wert.


    Ich analysiere meine Provider Logfiles alle zwei bis drei Tage. Dazu verwende ich Mescalero. Es ist 30 Tage kostenlos. In diesen Logfiles sehe ich ganz genau welche IP-Adresse was versucht hat. Gefällt mir das nicht, sperre ich diese IP-Adresse oder gar die ganze Domain für die Zukunft aus.


    Wir sollten per ICQ im WEB kommunizieren um der Sache auf den Grund zu gehen, so per Posting hat das keinen Sinn, zur Not must du dich halt mal bei ICQ registrieren wir können aber auch AIM nehmen.
    Wir können dann später unsere Erkenntnisse hier reinstellen.


    Ich vermute aber eher einen Fehler deinerseits beim Löschen von Usern.
    Aus irgendeinem Grund ist dann Deine Authenticate.php verschwunden. Ausgerechnet nachdem Du User gelöscht hast.
    Dann wäre alles halb so schlimm, sowas kriegt man wieder repariert.

    Gruß
    Michael Lauffs
    Aachen, Eschweiler, Stolberg
    ICQ# 48430007
    www.Lauffs.de

    Man sollte eine Dummheit nicht zweimal machen, es gibt doch so viele davon.

  • Hallo Michael!


    ICQ habe ich ja! ;)


    Ich habe gestern mal versucht die alten Backup-Dateien zurückzuladen.
    Hat soweit auch geklappt, nur das ich mich trotzdem nicht einloggen konnte. Bei den Dateien war auch die Authenticate.php .


    Da das nicht geklappt hatte, hatte ich mir die neueste Version von PGV runtergeladen, die alte Version auf dem Webspace gelöscht und die neuen 17 MB hochgeladen.
    Nachdem ich dann die Editconfig.php konfiguriert hatte, kam ich dann wieder zum Login. Und konnte mich natürlich nicht einloggen, da ich ja keinen Admin anlegen konnte.


    Irgendwie kapeire ich das nicht.


    Das Progrramm Mecalero habe ich mir mal runtergeladen und auch eine Auswertung der Log-Dateien machen lassen.
    Aber wirklich verdächtiges kann ich da nicht erkennen.
    Nur das ich am 12.06. ziemlich viele Bushcer auf meiner Seite hatte.
    Dabei wurde die login.php 36mal, die editconfig.php wurde vom 13.-17.06. 12mal aufgerufen.




    Gruß Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka

  • Okay, gut dass es wieder läuft.


    Komisch ist es schon, dass nach mehreren Aufrufen wichtiger Dateien PGV nicht mehr gescheit läuft.
    Grenze das Datum für eine mögliche Manipulation ein und schreibe mal an 1&1 ob die noch etwas in ihren Serverlogfiles finden können.


    Vielleicht lässt du mich mal mit in deine anderen Logfiles gucken, um mal zu sehen was da passiert ist.
    Ich prüfe parallel dazu meine Logfiles und schaue mal ob ich ähnliche Versuche sehen kann.


    Wenn Du online bist schmeiß mal ICQ an, ich habe Dich sogar in meiner Liste.

    Gruß
    Michael Lauffs
    Aachen, Eschweiler, Stolberg
    ICQ# 48430007
    www.Lauffs.de

    Man sollte eine Dummheit nicht zweimal machen, es gibt doch so viele davon.

  • Hi!


    Also PGV läuft nicht. Ich weiß auch nicht woran das liegt, ich komme einfach nicht dazu einen Admin anzulegen.


    Ich hatte mir die Auswertung von den Logfiles als HTML-Bericht speichern lassen.


    Nützt Dir das was? Oder sind Dir die ZIP-Files der Logdateien lieber?!




    Gruß Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka

  • Moin!


    Nachdem alles bei mir wieder super funktioniert hatte, wollte ich heute wieder ins PGV und da sagt mir der Bildschirm


    ERROR 403
    nicht ausreichend Rechte bla bla bla



    Ich habe aber nix an den Rechten rumgespielt, da ist alles beim Alten!


    Ich weiß es gibt eine Möglichkeit zu testen, ob auf dem Webspace PHP verfügbar ist. Man muss dann irgendeine Datei "info.php" oder so hochladen und dann aufrufen.
    Wenn es klappt ist PHP verfügbar, wenn nicht .... naja ..


    Weiß jemand wie dieser Selbsttest war?!


    Ich habe vor kurzen meinen Vertrag DSL-Vertrag geändert und der Webspace wurde dabei auch gleich von 100 auf 200 MB vergrößert.
    Nicht das die das jetzt geändert haben und nun kein PHP mehr habe.




    Gruß (der verzweifelte ) Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka

  • Hei,


    also Dich erwischt es ja schon mit merkwürdigen Dingen.


    Kommst Du per ftp dran ?
    Hast Du was an .htaccess gemacht ?


    Gehe mal mit ICQ online, ich bin da.

    Gruß
    Michael Lauffs
    Aachen, Eschweiler, Stolberg
    ICQ# 48430007
    www.Lauffs.de

    Man sollte eine Dummheit nicht zweimal machen, es gibt doch so viele davon.

  • Hallo


    öffne einen Texteditor und gib hier folgendes ein:


    <?php
    phpinfo();
    ?>


    speichern unter info.php


    auf Deinen Webspace laden und im Internetexplorer aufrufen.

    mit freundlichem Gruss


    Ulrich Holthausen

  • Hallo Ulrich!


    Genau diese Datei meinte ich. Danke!


    Und natürlich ist kein Php mehr vorhanden.
    Da muss ich wohl mal nachfragen, ob sie es mir wieder installieren.
    Wenn nicht können sie sich auch das Aufstocken des Webspace klemmen. Was funktioniert denn heute noch ohne Php.




    Gruß Gordon

    Wer Rechtschreibfehler findet, darf sie gern behalten! :rolleyes:
    * * * * * * * * * * * * * * * * * * * * * * *
    Auf der Suche nach Mahnke, Dahl, Hackbusch, Lange, Pägelow, Manka